User Tools

Site Tools


networking:switch:dell_8024

Dell PowerConnect 8024 10GbE Enterprise Switch

Replacement Fan

This fan must be re-pinned before applying power or the fan will be damaged!

Delta FFB0412SHN-F00

  • 40x40x28mm
  • 3-pin
  • 13K RPM
  • Tach signal on blue/yellow
  • Pinned red-blue-black (red-yellow-black) from pin marked 1

Delta FFB0412SHN-F00

Initial Configuration

:!: You can use a Cisco console cable and the CLI is very much like Cisco IOS.

:!: Connect to the serial console: 9600,N,8,1

Use the Getting Started Guide listed above.

Set the 'enable' password:

configure
enable password xxxxx

To enable SSH and web console, enter the following commands:

enable
configure
username xxx password xxx privilege 15
crypto key generate rsa
crypto key generate dsa
ip ssh server

To disable telnet, enter:

ip telnet server disable

To enable HTTPS, enter the following commands:

FIXME Untested

crypto certificate 1 generate key
ip https certificate 1
ip http secure-server

To disable HTTP:

no ip http server
exit

After verifying connectivity via SSH or HTTPS, save the configuration by entering:

copy running-config startup-config

CLI Basics

enable
configure
show running-config
copy startup-config backup-config
copy running-config startup-config

Out-of-Band (OOB) Management Interface

enable
configure

interface out-of-band
ip address <ip_address> <subnet_mask> [gateway_ip]
CTRL + Z

show ip interface out-of-band

Enable Jumbo Frames

Access ports:

Switch1> enable
Switch1# configure
Switch1(config)# interface range ethernet all
Switch1(config-if-ch1)# mtu 9216
Switch1(config-if-ch1)# exit
Switch1(config)# exit

Trunk ports:

FIXME

Switch1> enable
Switch1# configure
Switch1(config)# interface port-channel 1
Switch1(config-if-ch1)# mtu 9216

Create VLANs

:!: Ranges may be specified like:

interface range te1/0/2,te1/0/4,te1/0/6,te1/0/8,te1/0/10,te1/0/12,te1/0/16-20

Display current VLAN information:

top_switch> enable
top_switch # show vlan

Set the CLI to configuration mode and define VLAN:

top_switch # configure
top_switch(config)# vlan database
top_switch(config-vlan)# vlan 101-102, 310
top_switch(config-vlan)# exit

Setting the port to an access VLAN port in VLAN 101.

  • Ethernet traffic on this port will be untagged
  • All the traffic will be in VLAN 101
  • GVRP enable sets the port to dynamically register and de-register VLAN membership information with the MAC networking switches attached to the same segment
top_switch(config)# interface Ethernet 1/xg1
top_switch(config)# switchport access vlan 101
top_switch(config-if-1/xg1)# gvrp enable
top_switch(config-if-1/xg1)# exit

Setting the port to an access VLAN port in VLAN 102.

  • Ethernet traffic on this port will be untagged
  • All the traffic will be in VLAN 102
top_switch(config)# interface Ethernet 1/xg2
top_switch(config-if-1/xg2)# switchport access vlan 102
top_switch(config-if-1/xg2)# gvrp enable
top_switch(config-if-1/xg2)# exit

Setting the port to an access VLAN port in VLAN 310.

  • Ethernet traffic on this port will be untagged
  • All the traffic will be in VLAN 310:
top_switch(config)# interface range Ethernet 1/xg3-1/xg16
top_switch(config-if)# switchport access vlan 310
top_switch(config-if)# gvrp enable
top_switch(config-if)# exit

To set the port type to an 802.1Q VLAN (to allow multiple tagged VLANs), use the switchport mode general command.

  • Remove the port membership from VLAN 1
    • All ports are in VLAN 1 by default)
    • Using switchport mode general allowed vlan remove 1 command
top_switch(config)# interface ethernet 1/xg20
top_switch(config-if-1/xg20)# switchport mode general
top_switch(config-if-1/xg20)# switchport general allowed vlan add 101,102-310
top_switch(config-if-1/xg20)# switchport general allowed vlan remove vlan 1
top_switch(config-if-1/xg20)# gvrp enable
top_switch(config-if-1/xg20)# exit
top_switch(config)# gvrp enable
top_switch(config)# end

Display interface status:

top_switch# show interfaces switchport ethernet 1/xg1
top_switch# show interfaces switchport ethernet 1/xg2
top_switch# show interfaces switchport ethernet 1/xg20
top_switch# show vlan

Remove ports from the VLANS and disable gvrp:

top_switch(config)# interface ethernet 1/xg20
top_switch(config-if-1/xg20)# switchport general allowed vlan remove 101-102,310
top_switch(config-if-1/xg20)# no gvrp enable
top_switch(config)# exit
top_switch(config)# interface ethernet 1/xg1
top_switch(config-if-1/xg1)# switchport access vlan 1
top_switch(config-if-1/xg1)# no gvrp enable
top_switch(config-if-1/xg1)# exit
top_switch(config)# interface Ethernet 1/xg2
top_switch(config-if-1/xg2)# switchport access vlan 1
top_switch(config-if-1/xg2)# no gvrp enable
top_switch(config-if-1/xg2)# exit
top_switch(config)# interface range ethernet 1/xg3-1/xg16
top_switch(config-if)# switchport access vlan 1
top_switch(config-if)# no gvrp enable
top_switch(config-if)# exit
top_switch(config)# vlan database
top_switch(config-vlan)# no vlan 101-102,310
top_switch(config-vlan)# end
top_switch(config)# no gvrp enable
top_switch(config)# exit
top_switch(config)# show vlan
  1. Configure the switch to enable LACP
  2. Configure the client/host for LACP

Create Dynamic LACP LAG

PowerConnect Switch:

console> enable
console# configure
console(config)# interface range te1/0/1-2
console(config-if)# channel-group 1 mode active
console(config-if)# exit
console(config)#

OmniOS (UNIX) Client:

ifconfig
ipadm show-if

ipadm delete-if ixgbe0
ipadm delete-if ixgbe1
ipadm show-if

dladm create-aggr -l ixgbe0 -l ixgbe1 aggr2
dladm modify-aggr -L active -T long aggr2

ipadm create-addr -T static -a 123.123.123.123/24 aggr2/v4
ifconfig
networking/switch/dell_8024.txt · Last modified: 2021/12/20 10:33 by gcooper