User Tools

Site Tools


networking:router:mikrotik_ap

Mikrotik Wireless Access Points

cAP XL ac

While it appears this is a very capable Wireless Access Point, this AP comes from the factory configured as a router, with firewall and everything! Worse, it appears there is no “Simple AP” choice in QuickSet.

Multi-AP Installations

For multi-access-point installations, you should learn and use CAPSMAN.

You must power the AP with ether1 (Interent) and you must program it via wireless or ether2.

Home AP

For a simple home AP, you can default the programming (factory reset) and select No Default Configuration, then modify and apply this simple script.

  • Bridges all ports to the LAN
  • ether1 connects to LAN and PoE
  • ether2 can be used to daisy-chain another AP or device
  • Permits management on all ports
  • WPA2 security with a pre-shared key
  • Sets AP as DHCP client for IP address
    • Use DHCP reservation if desired
  • Sets AP hostname
# Create a LAN bridge
/interface bridge add name=LAN

# Configure wireless security
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
add authentication-types=wpa2-psk mode=dynamic-keys name=Secure supplicant-identity="" \
  wpa2-pre-shared-key=<YourWiFiPassword>

# Configure wireless interfaces - SSIDs can be the same
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n country="united states" disabled=no mode=ap-bridge \
  security-profile=Secure ssid=<Your-2GHz-Network-Name>
set [ find default-name=wlan2 ] band=5ghz-a/n/ac channel-width=20/40/80mhz-XXXX disabled=no mode=ap-bridge \
  security-profile=Secure ssid=<Your-5GHz-Network-Name>

# Add all interfaces to the bridge
/interface bridge port add bridge=LAN interface=all

# Enable DHCP client so AP gets a management address
/ip dhcp-client add disabled=no interface=LAN

# Set the AP hostname
/system identity set name=<YourAPHostname>
networking/router/mikrotik_ap.txt · Last modified: 2022/12/29 13:22 by gcooper