User Tools

Site Tools


networking:router:mikrotik_sw_vs_bridge

This is an old revision of the document!


Mikrotik Switch Ports vs. Bridge

FIXME need test

Faster Packet Processing

You may get significantly faster packet processing and lower CPU utilization by removing ports from a bridge, where possible, to add them to a switch group.

When router ports are bridged, all packets going through these interface are processed using the router's CPU. However, if the ports are in the same switch group, the special switch chip processes those packets, decreasing load on CPU.

So, in the case of an RB2011 with two switches and ten Ethernet ports, you can make ether1-master to be a 'master' port for ether2 through ether5 and ether6-master the master for ether7 through ether10.

:!: Don't forget that before assigning master port you must remove them from any bridge.

/interface ethernet
  set ether1 master-port=none
  set ether2 master-port=ether1
  set ether3 master-port=ether1
  set ether4 master-port=ether1
  set ether5 master-port=ether1
  set ether6 master-port=none
  set ether7 master-port=ether6
  set ether8 master-port=ether6
  set ether9 master-port=ether6
  set ether10 master-port=ether6

After doing that you'll get two separate and independent switch groups, however, as you mentioned it in your post, you want them to be connected. In such case, there are two options:

  1. Use a software bridge
  2. Connect them using a cable

Software (CPU) bridging

In this case, switch groups 1 and 2 will be switched using CPU, so any packet going from any interface in group 1 to group 2, or vice versa, will be processed using CPU.

/interface bridge
  add name=bridge-local
  port add interface=eth1 bridge=bridge-local
  port add interface=eth6 bridge=bridge-local

NOTE: don't forget to assign an IP address to the bridge and, if you're using DHCP server on Mikrotik, change its interface to bridge-local as well.

/ip address add interface=bridge-local address=192.168.1.1/24
/ip dhcp-server add interface=bridge-local address-poll=[name of your address pool]

Patch Cord

Just connect any port from group 1 (ether1-5) to any port in group 2 (ether6-10). Yes, it takes 2 port and only applicable if you have ones. If all ports in one of the switch groups are already in use, I'd suggest using first option (bridging).

networking/router/mikrotik_sw_vs_bridge.1478703426.txt.gz · Last modified: 2016/11/09 07:57 by gcooper