This is an old revision of the document!
http://wiki.mikrotik.com/wiki/Manual:Switch_Chip_Features
http://wiki.mikrotik.com/wiki/Manual:CRS_features
http://wiki.mikrotik.com/wiki/Manual:CRS_examples
http://wiki.mikrotik.com/wiki/Manual:Interface/VLAN
Interesting: http://forum.mikrotik.com/viewtopic.php?f=13&t=82386
The switching feature allows wire speed traffic passing among a group of ports, like the ports were a regular Ethernet switch. You configure this feature by setting a “master-port” property to one ore more ports in /interface Ethernet menu.
A 'master' port will be the port through which RouterOS will communicate to all ports in the group. Interfaces for which the 'master' port is specified become inactive - no traffic is received on them and no traffic can be sent out.
Passing a packet 'up' or giving it to RouterOS is also called sending it to switch chips' 'cpu' port.
/interface ethernet switch print /interface ethernet print
Here we divide the switch into two 12-port switch groups.
We are routing via the SFP port.
Remove default slave configuration, define two master ports and assign the slave ports:
/interface ethernet set [find master-port=ether2-slave-local] master-port=none set 0 name=ether1-master-local set 12 name=ether13-master-local set 1,2,3,4,5,6,7,8,9,10,11 master-port=ether1-master-local set 13,14,15,16,17,18,19,20,21,22,23 master-port=ether13-master-local print
The SFP port is the gateway.
Here we add IP addresses for the upstream link and the two master switch ports:
/ip address add address=172.16.1.2/30 interface=sfp1-gateway comment="VA - Gateway to upstream TOR router" add address=198.167.189.17/28 interface=ether13-master-local comment="VA - Gateway for External Hosting" add address=10.10.4.1/24 interface=ether1-master-local comment="VA - Gateway for OoBM (IPMI)" print
Then we remove the default management IP address (192.168.88.1), if it exists:
remove numbers=0
/ip route
add comment=“Default Route” gateway=172.16.1.1
Neighbor discovery is a broadcast protocol limited to the broadcast domain.
Here we disable neighbor discovery except on the gateway port connected to our upstream router:
/ip neighbor discovery set ether1-master-local,ether13-master-local discover=no