UNIX Link Aggreagation (Bonding)

:!: Possibly applies to Solaris, OmniOS, Illumos, OpenIndiana, etc.

http://www.isartor.org/wiki/Solaris_Link_Aggregation

http://blog.allanglesit.com/2011/03/solaris-11-network-configuration-advanced/

http://pvssraju.wordpress.com/2009/08/19/how-to-create-a-link-aggregation-bonding-on-solaris/

Show Info

Show existing physical interface and link information:

dladm show-phys
dladm show-link
dladm show-ether
dladm show-aggr

Show existing IP configuration and delete:

ipadm show-if
ipadm delete-if e1000g0

Create the bond specifying the interfaces to include and add a static IP address:

dladm create-aggr -l e1000g0 -l e1000g1 aggr0
ipadm create-addr -T static -a 192.168.1.100/24 aggr0/v4

Delete a bond:

ipadm delete-if aggr0
dladm delete-aggr aggr0

FIXME Add LACP bonding to switch that supports LACP.

http://serverfault.com/questions/537705/configuring-lacp-between-openindiana-solaris-and-a-cisco-c3560

:!: If you are using the bond to communicate with the server, you will lose connectivity on the next step.

Enable LACP on the server side:

dladm modify-aggr -L active -T long aggr0

Add interfaces to a bond:

dladm add-aggr -d e1000g1 -d e1000g3 aggr1

Show routes:

netstat -nr

Add a route:

Ephemeral:

route add default <ipaddress>

Persistent:

echo <ipaddress> > /etc/defaultrouter