====== Mikrotik Switch Ports vs. Bridge ====== FIXME need test ===== Faster Packet Processing ===== You may get significantly faster packet processing and lower CPU utilization by removing ports from a bridge, where possible, to add them to a switch group. **When router ports are bridged, all packets going through these interface are processed using the router's CPU**. However, **if the ports are in the same switch group, the special switch chip processes those packets, decreasing load on CPU**. ===== Example ===== So, in the case of an RB2011 with two switches and ten Ethernet ports, you could: * make ''ether1-gateway'' the Internet (WAN) gateway * make ''ether2-master'' to be a 'master' port for ''ether3'' through ''ether5'' * make ''ether6-master'' the master for ''ether7'' through ''ether10'' :!: Don't forget that before assigning master port you must remove them from any bridge. /interface set ether1 name=ether1-gateway set ether2 name=ether2-master set ether3 name=ether3-slave set ether4 name=ether4-slave set ether5 name=ether5-slave set ether6 name=ether6-master set ether7 name=ether7-slave set ether8 name=ether8-slave set ether9 name=ether9-slave set ether10 name=ether10-slave /interface ethernet set ether1 master-port=none set ether2 master-port=none set ether3 master-port=ether2 set ether4 master-port=ether2 set ether5 master-port=ether2 set ether6 master-port=none set ether7 master-port=ether6 set ether8 master-port=ether6 set ether9 master-port=ether6 set ether10 master-port=ether6 After doing that you'll have a WAN (gateway) port plus two separate and independent switch groups. Assuming you want them to be connected (LAN bridge), there are two options: - Use a software bridge * Perhaps ''sfp1'' + ''ether2-master'' + ''ether6-master'' - Connect them using a cable * Wastes physical ports ===== Software (CPU) bridging ===== In this case, traffic between switch groups ''switch1'' and ''switch2'' will be processed using the CPU, so any packet going from any interface in group 1 to group 2, or vice versa, will be processed using CPU. /interface bridge add name=bridge-local port add interface=ether2 bridge=bridge-local port add interface=ether6 bridge=bridge-local port add interface=sfp1 bridge=bridge-local Don't forget to assign an IP address to the bridge and, if you're using DHCP server on Mikrotik, change its interface to ''bridge-local'' as well. /ip address add interface=bridge-local address=192.168.1.1/24 /ip dhcp-server add interface=bridge-local address-pool=[name of your address pool] ===== Patch Cord ===== While rarely done, you //can// just connect any port from group 1 (ether2-5) to any port in group 2 (ether6-10). Generally, we suggest using the first option (bridging).